Dacă nu ați actualizat de curând player-ul VLC aveți grijă ce filme rulați și mai ales din ce sursă: e posibil să vă infectați PC-ul.

Cei ce folosesc player-ul VLC ar face bine să îi actualizeze rapid și să selecteze cu grijă sursele din care își iau materiale video pentru că e posibil să își infecteze PC-ul și nici să nu își dea seama de treaba asta.

Pentru că versiunile de VLC de Windows mai vechi de 3.0.7 au două vulnerabilități critice, pe lângă altele medii și mici, care pot duce la posibilitatea de rulare de cod malware de la distanță. Mai exact, Symeon Paraschoudis de la Pen Test Partners a descoperit vulnerablitatea CVE-2019-12874 în funcția “zlib_decompress_extra” din VideoLAN VLC player și poate fi exploatată printr-un fișier MKV special creat, randat prin Matroska demuxer.

A doua problemă la fel de periculoasă este CVE-2019-5439, o vulnerabilitate read-buffer overflow din funcția “ReadFrame” care poate fi exploatată cu un fișier video AVI creat special pentru treaba asta.

În acest moment nu se cunosc exploit-uri publice pentru cele două vulnerabilități, altele decât cele prezentate de cei ce le-au descoperit și care duc întreruperea execuției aplicației, dar e posibil ca prin code dedicat să se poată obține accesul cu drepturi crescute pe sistem.

Astfel de situații sunt o țintă dorită de hackeri pentru că site-urile de torrente permit o plajă de atac fenomenală ca urmare a faptului că mulți utilizatori preferă să descarce și să urmărească materiale pirat pentru filmele și show-urile preferate.

Conform dezvoltatorilor de la VideoLAN, cu protecția ASLR și DEP riscul se reduce, dar nu este eliminat. Singura rezolvare este update-ul rapid de VideoLAN.

via VLC

LĂSAȚI UN MESAJ

Please enter your comment!
Please enter your name here